EMAIL SUPPORT

dclessons@dclessons.com

LOCATION

NZ

VRRP Concepts

VRRP Concepts

Posted on Jan 24, 2020 (0)

VRRP Concepts

Virtual Router Redundancy Protocol is the industry standard FHRP protocol which enables two or more routers to provide first-hop redundancy services for IP traffic.

  • In VRRP one router is Master and all other are in backup state.
  • Master router is responsible for ARP resolution and forwarding all traffic.
  • All the routers/switch participating in Master for a Single VLAN must be in same group.
  • You can configure 255 groups at maximum in VRRP.
  • The Master router has virtual IP address which in turn has Virtual MAC address for ARP resolution or it can use same Physical IP of interface.
  • If Master router fails then second best backup router will resume the Master state with same Virtual MAC address.
  • There is preemption enabled by default.
  • VRRP hello packets are used to elect the Master router, those who has Highest Priority will become Master router on multicast address 224.0.0.18.
  • Hello Timer is 1 Sec and Hold down Timer is 3 sec.
  • Default Priority of router is 100 and if all router has same priority then Highest IP address of device will be used to elect the Master.
  • In Nexus VRRP is enabled by enabling feature command.
  • In VRRP, VRRP packets can also be secured by HSRP authentication method.
  • VRRP uses plain-text method to secure its packets.

TASK:

Configure VRRP as per following topology.

  • Configure Po100 as trunk between N7K1 and N7K2
  • Configure VLAN 200 with VIP 200.200.200.200 and use any IP for Physical interface SVI.
  • On N7K1 configure Priority 200 and VRRP group 200 for VLAN 200
  • On N7K2 configure Priority 100 and VRRP group 100 for VLAN 200
  • Use Authentication method Plain Text and key CCIE.

Topology: 

N7K1(config)# feature vrrp
N7K1(config)# feature interface-vlan
N7K1(config)# feature lacp
N7K1(config)# vlan 200
!
N7K1(config)# conf t
N7K1(config)# int eth1/1-2
N7K1(config-if-range)# switchport
N7K1(config-if-range)# switchport mode trunk
N7K1(config-if-range)# channel-group 100 mode active
N7K1(config-if-range)# no shut
!
N7K1(config)# int po100
N7K1(config-if)# switchport
N7K1(config-if)# switchport mode trunk
N7K1(config-if)# no shut
N7K1(config-if)#
!
N7K1(config)# int vlan 200
N7K1(config-if)# ip address 200.200.200.2/24
N7K1(config-if)# no shut
N7K1(config-if)# vrrp 200
N7K1(config-if-vrrp)# address 200.200.200.200
N7K1(config-if-vrrp)# priority 200
N7K1(config-if-vrrp)# authentication text CCIE
N7K1(config-if-vrrp)# no shut
N7K1(config-if-vrrp)#
!

 

N7K2(config)# feature vrrp
N7K2(config)# feature lacp
N7K2(config)# feature interface-vlan
N7K2(config)# vlan 200
N7K2(config-vlan)#
!
N7K2(config)# int eth1/1-2
N7K2(config-if-range)# switchport
N7K2(config-if-range)# switchport mode trunk
N7K2(config-if-range)# channel-group 100 mode active
N7K2(config-if-range)# no shut
N7K2(config-if-range)# exit
N7K2(config)# int po100
N7K2(config-if)# switchport
N7K2(config-if)# switchport mode trunk
N7K2(config-if)# no shut
N7K2(config-if)#
!
N7K2(config)# int vlan 200
N7K2(config-if)# ip address 200.200.200.3/24
N7K2(config-if)# no shut
N7K2(config-if)# vrrp 200
N7K2(config-if-vrrp)# address 200.200.200.200
N7K2(config-if-vrrp)# priority 100
N7K2(config-if-vrrp)# authentication text CCIE
N7K2(config-if-vrrp)# no shut
N7K2(config-if-vrrp)#
!

Verification:




Comment

    You are will be the first.

LEAVE A COMMENT

Please login here to comment.