EMAIL SUPPORT

dclessons@dclessons.com

LOCATION

NZ

OTV Single Edge Device – Multicast Mode Configuration

OTV Single Edge Device – Multicast Mode Configuration

Posted on Jan 24, 2020 (0)

OTV Single Edge Device - Multicast Mode Configuration

Let’s discuss that what are the configuration steps required when we want to configure OTV on Single Edge device on Multicast Mode. Here we are not doing end to end configuration and verification, however we are discussing only steps:

Step1: Configure OTV VDC VLAN which are to be extended and Site VLAN.

Here VLAN 2-10 are Data VLAN which is to be extended and VLAN 20 is Site VLAN.

OTV-VDC-A(config)# vlan 2-10, 20

Step2: Configure Join Interface and L3 interface on another Agg VDC and enable PIM.

OTV-VDC-A(config)# interface ethernet 1/2
OTV-VDC-A(config-if)# description #### OTV Join-Interface ####
OTV-VDC-A(config-if)# ip address 192.168.1.10/30
OTV-VDC-A(config-if)# ip igmp version 3
OTV-VDC-A(config-if)# no shutdown
!
AGG-VDC-A(config)# interface ethernet 1/1
AGG-VDC-A(config-if)# description #### Connected to OTV Join-Interface ####
AGG-VDC-A(config-if)# ip address 192.168.1.11/30
AGG-VDC-A(config-if)# ip pim sparse-mode
AGG-VDC-A(config-if)# ip igmp version 3
AGG-VDC-A(config-if)# no shutdown

The assumption is that PIM is already configured on the aggregation VDC.

Step 3: Configure Internal Interface on both side OTV VDC and AGG VDC.

interface ethernet 2/1-2/2
description [ OTV Internal Interface ]
switchport
switchport mode trunk
switchport trunk allowed vlan 2-10, 20
no shutdown

Step:4 Configure Overlay Interface for multicast enabled transport infrastructure

OTV-VDC-A(config)# feature otv
OTV-VDC-A(config)# otv site-identifier 0x1
OTV-VDC-A(config)# otv site-vlan 20
!
OTV-VDC-A(config)# interface overlay 1
OTV-VDC-A(config-if)# otv join-interface ethernet 1/2
OTV-VDC-A(config-if)# otv control-group 239.1.1.1
OTV-VDC-A(config-if)# otv data-group 232.1.2.0/24
OTV-VDC-A(config-if)# otv extend-vlan 2-10
OTV-VDC-A(config-if)# no shutdown

Verification: Verify the OTV edge device joined the Overlay, discovered the other edge devices in the remote sites, and established OTV control plane adjacency.

OTV-VDC-A# sh otv overlay 1
OTV-VDC-A# show otv adjacency
OTV-VDC-A# show otv route

 


Comment

    You are will be the first.

LEAVE A COMMENT

Please login here to comment.