EMAIL SUPPORT

dclessons@dclessons.com

LOCATION

NZ

LAB:Configuring vPC & its Components

LAB:Configuring vPC & its Components

Posted on Jan 24, 2020 (0)

LAB:Configuring vPC & its Components

Topology:

Task:

Configure the vPC system as per topology and as per task given below.

  • Configure vPC domain 100 between N7K1 and N7K2
  • Configure N7K1 with Role priority 10 and N7K2 with Role Priority 20
  • Configure Peer-keepalive link between N7k1 and n7K2 on mgmt0 link.
  • Configure LACP port-channel port Eth1/1 and Eth1/2 on both N7K1 and N7K2 and use it as peer-link
  • Configure Eth1/3 on vPC 10 and Eth1/4 on vPC 20 on N7K1 and same on N7K2.
  • Configure Eth1/3 and Eth1/4 on N5K1 on Port channel 10 and Eth1/3 and Eth1/4 on N5K2 on Port channel 20.
  • Configure Layer 2 VLAN VLAN 10, VLAN 20, and VLAN 30 on All Four Switch
  • Configure N7K1 as STP Root Bridge.
  • Configure Eth1/5 on VLAN 10 on Both N5K1 and N5K2. Assign HOST 1 with IP 10.10.10.4 and Host with IP 10.10.10.5
  • Verify the Connectivity vPC and Connectivity between Host 1 and Host 2.

Solution:

TASK 1: Configure vPC domain 100 between N7K1 and N7K2, Configure N7K1 with Role priority 10 and N7K2 with Role Priority 20 and Configure Peer-keepalive link between N7k1 and n7K2 on mgmt0 link. Configure LACP port-channel port Eth1/1 and Eth1/2 on both N7K1 and N7K2 and use it as peer-link

NEXUS 7K1 Configuration:
N7K1(config)# feature lacp
N7K1(config)# feature vpc
N7K1(config)# feature interface-vlan
N7K1(config)# vpc domain 100
N7K1(config-vpc-domain)# role priority 10
N7K1(config-vpc-domain)# peer-keepalive destination 192.168.1.2 source 192.168.1.1 vrf management
N7K1(config-vpc-domain)# exit
!
N7K1(config)# int eth1/1-2
N7K1(config-if-range)# switchport
N7K1(config-if-range)# switchport mode trunk
N7K1(config-if-range)# channel-group 100 mode active
N7K1(config-if-range)# no shut
N7K1(config-if-range)# exit
N7K1(config)# int po100
N7K1(config-if)# switchport
N7K1(config-if)# switchport mode trunk
N7K1(config-if)# vpc peer-link
N7K1(config-if)# no shut
N7K1(config-if)#exit
!
NEXUS 7K2 Configuration:
N7K2(config)# feature lacp
N7K2(config)# feature vpc
N7K2(config)# feature interface-vlan
N7K2(config)# vpc domain 100
N7K2(config-vpc-domain)# role priority 20
N7K2(config-vpc-domain)# peer-keepalive destination 192.168.1.1 source 192.168.1.2 vrf management
N7K2(config-vpc-domain)# exit
!
N7K2(config)# int eth1/1-2
N7K2(config-if-range)# switchport
N7K2(config-if-range)# switchport mode trunk
N7K2(config-if-range)# channel-group 100 mode active
N7K2(config-if-range)# no shut
N7K2(config-if-range)# exit
N7K2(config)# int po100
N7K2(config-if)# switchport
N7K2(config-if)# switchport mode trunk
N7K2(config-if)# vpc peer-link
N7K2(config-if)#exit
N7K2(config-if)# no shut

vPC domain Verification and Peer-link verification:

Varification1: Verify vPC Role and keepalive parameters and Port-channel

Here we can see that on both N7K1 and N7K2 the vPC system MAC address is same:  00:23:04:ee:be:64 derived by domain 100. N7K1 is Primary with Role priority 10 and N7K2 is secondary with Role Priority 20.

The keepalive verification states keepalive parameters highlighted in Red Block.

TASK 2: Configure Eth1/3 on vPC 10 and Eth1/4 on vPC 20 on N7K1 and same on N7K2. Configure Eth1/3 and Eth1/4 on N5K1 on Port channel 10 and Eth1/3 and Eth1/4 on N5K2 on Port channel 20

N7K1(config)# int eth1/3
N7K1(config-if)# switchport
N7K1(config-if)# switchport mode trunk
N7K1(config-if)# channel-group 10 mode active
N7K1(config-if)# no shut
N7K1(config-if)# int eth1/4
N7K1(config-if)# switchport
N7K1(config-if)# switchport mode trunk
N7K1(config-if)# channel-group 20 mode active
N7K1(config-if)# exit
N7K1(config)# int po20
N7K1(config-if)# switchport
N7K1(config-if)# switchport mode trunk
N7K1(config-if)# no shut
N7K1(config-if)# int po10
N7K1(config-if)# switchport
N7K1(config-if)# switchport mode trunk
N7K1(config-if)# no shut
N7K1(config-if)# vpc 10
N7K1(config-if)# int po20
N7K1(config-if)# vpc 20
!
N7K2(config)# int eth1/3
N7K2(config-if)# switchport
N7K2(config-if)# switchport mode trunk
N7K2(config-if)# channel-group 20 mode active
N7K2(config-if)# no shut
N7K2(config-if)# int eth1/4
N7K2(config-if)# switchport
N7K2(config-if)# switchport mode trunk
N7K2(config-if)# channel-group 10 mode active
N7K2(config-if)# no shut
N7K2(config-if)# exit
N7K2(config)# int po10
N7K2(config-if)# switchport
N7K2(config-if)# switchport mode trunk
N7K2(config-if)# int po20
N7K2(config-if)# switchport
N7K2(config-if)# switchport mode trunk
N7K2(config-if)# no shut
N7K2(config-if)# vpc 20
N7K2(config-if)# int po10
N7K2(config-if)# vpc 10
!
N5K1(config)# feature lacp
N5K1(config)# int eth1/3-4
N5K1(config-if-range)# switchport
N5K1(config-if-range)# switchport mode trunk
N5K1(config-if-range)# channel-group 10 mode active
N5K1(config-if-range)# no shut
N5K1(config-if-range)# exit
N5K1(config)# int po10
N5K1(config-if)# switchport
N5K1(config-if)# switchport mode trunk
N5K1(config-if)# no shut
N5K1(config-if)#
N5K1#
!
N5K2(config)# feature lacp
N5K2(config)# int eth1/3-4
N5K2(config-if-range)# switchport
N5K2(config-if-range)# switchport mode trunk
N5K2(config-if-range)# channel-group 20 mode active
N5K2(config-if-range)# no shut
N5K2(config-if-range)# exit
N5K2(config)# int po20
N5K2(config-if)# switchport
N5K2(config-if)# switchport mode trunk
N5K2(config-if)# no shut
N5K2(config-if)#

Verification2: Verify vPC , vPC Member Port and LACP neighbor , CFS status

The vPC verification shows that Peer-link is UP and Keepalive is also UP. There is no Consistency error between them and default Graceful Consistency Check  is Enabled.

Task 3: Configure Layer 2  VLAN 10, VLAN 20, and VLAN 30 on All Four Switch. Configure N7K1 as STP Root Bridge. Configure Eth1/5 on VLAN 10 on Both N5K1 and N5K2. Assign HOST 1 with IP 10.10.10.4 and Host with IP 10.10.10.5.Verify the Connectivity vPC and Connectivity between Host 1 and Host 2.

N7K1(config)# vlan 10
N7K1(config-vlan)# vlan 20
N7K1(config-vlan)# vlan 30
N7K1(config-vlan)#
N7K1(config)# spanning-tree vlan 10,20,30 priority 4096
!
N7K2(config)# vlan 10
N7K2(config-vlan)# vlan 20
N7K2(config-vlan)# vlan 30
N7K2(config-vlan)#
N7K2(config)# spanning-tree vlan 10,20,30 priority 8192
!
N5K1(config)# vlan 10
N5K1(config-vlan)# vlan 20
N5K1(config-vlan)# vlan 30
N5K1(config-vlan)#
N5K2(config)# vlan 10
N5K2(config-vlan)# vlan 20
N5K2(config-vlan)# vlan 30
!
N5K1(config)# int eth1/5
N5K1(config-if)# switchport
N5K1(config-if)# switchport mode access
N5K1(config-if)# switchport access vlan 10
N5K1(config-if)# no shut
N5K1(config-if)#
N5K2(config)# int eth1/5
N5K2(config-if)# switchport
N5K2(config-if)# switchport mode access
N5K2(config-if)# switchport access vlan 10
N5K2(config-if)# no shut

Verification 3:

Ping from Host 2 to Host 1 and also the STP states.

Above configuration states that N7K1 is the root Bridge and N7K2 is not root bridge.


Comment

    You are will be the first.

LEAVE A COMMENT

Please login here to comment.