EMAIL SUPPORT

dclessons@dclessons.com

LOCATION

NZ

LAB: Configuring EIGRP & Features

LAB: Configuring EIGRP & Features

Posted on Jan 24, 2020 (0)

LAB: Configuring EIGRP & Features

Topology: 

TASK:

  • Configure the L2 Vlan 100 on both N7k1 and N7k2 and configure the Port-channel trunk between two switches using LACP protocols
  • Configure Interface Vlan 100 IP 10.100.100.1/24 on N7k 1 and 10.100.100.2/24 N7k2
  • Configure the Eigrp on Vlan 100 between two core switches use any AS number
  • Configure Following Loopback address on N7k1 Loopback0 : 192.168.128.1/24 and Loopback1: 192.168.143.1/24
  • Advertise these two loopback address on the Eigrp
  • Advertise the Summery address 192.168.128.0/20 from N7k1 towards N7k2
  • Configure the Eigrp Stub feature on N7k1 under address family
  • Configure the Eigrp MD5 Authentication between N7k1 and N7k2 with Key CCIEDC
  • Configure the static default route on N7k1  and advertise this route in such a way so that it reaches to N7k2 , but don’t use redistribute static on Eigrp AS
  • Configure to limit no of Prefix redistributed to eigrp from max 100 to in 25 .

Solution:

N7K-4-1# conf t
Enter configuration commands, one per line. End with CNTL/Z.
N7K-4-1(config) # vlan 100
N7K-4-1(config-vlan) #
!
N7K-4-2# conf t
Enter configuration commands, one per line. End with CNTL/Z.
N7K-4-2(config) # vlan 100
N7K-4-2(config-vlan) #
!
N7K-4-1(config) # feature interface-vlan
N7K-4-1(config) # feature lacp
N7K-4-1(config) # feature eigrp
N7K-4-1(config) #
!
N7K-4-2(config) # feature interface-vlan
N7K-4-2(config) # feature lacp
N7K-4-2(config) # feature eigrp
!
N7K-4-1(config) # int eth1/9-10
N7K-4-1(config-if-range) # channel-group 100 mode active
N7K-4-1(config-if-range) # no shut
N7K-4-1(config) # int po100
N7K-4-1(config-if) # switchport mode trunk
N7K-4-1(config-if) # no shut
!
N7K-4-2(config) # int eth1/9-10
N7K-4-2(config-if-range) # channel-group 100 mode active
N7K-4-2(config-if-range) # no shut
N7K-4-2(config-if-range) # exit
N7K-4-2(config) # int po100
N7K-4-2(config-if) # switchport mode trunk
N7K-4-2(config-if) # no shut

Verification 1: Verify Port-channel status.

N7K-4-1(config) # int vlan 100
N7K-4-1(config-if) # ip address 100.100.100.1/24
N7K-4-1(config-if) # no shut
!
N7K-4-2(config) # int vlan 100
N7K-4-2(config-if) # ip address 100.100.100.2/24
N7K-4-2(config-if) # no shut
!
N7K-4-1(config) # router eigrp 200
N7K-4-2(config) # router eigrp 200
!
N7K-4-1(config) # int vlan 100
N7K-4-1(config-if) # ip router eigrp 200
N7K-4-2(config) # int vlan 100
N7K-4-2(config-if) # ip router eigrp 200

Verification 2: Verify Eigrp Neighbour

N7K-4-1(config) # int loopback 0
N7K-4-1(config-if) # ip address 192.168.128.1/24
N7K-4-1(config-if) # int loopback 1
N7K-4-1(config-if) # ip address 192.168.143.1/24
!
N7K-4-1(config) # int loopback 0
N7K-4-1(config-if) # ip router eigrp 200
N7K-4-1(config-if)# int loopback 1
N7K-4-1(config-if) # ip router eigrp 200

Verification 3: Check the Routes learned from EIGRP

N7K-4-1(config) # int vlan 100
N7K-4-1(config-if) # ip summary-address eigrp 200 192.168.128.0/20
!
N7K-4-1(config) # router eigrp 200
N7K-4-1(config-router) # address-family ipv4 unicast

Verification 4: Verify Summery address

N7K-4-1(config) # router eigrp 200
N7K-4-1(config-router) # address-family ipv4 unicast
N7K-4-1(config-router-af) # stub direct

Verification 5: Check stub status

N7K-4-1(config) # key chain NEXUS
N7K-4-1(config-keychain) # key 1
N7K-4-1(config-keychain-key) # key-string CCIEDC
N7K-4-1(config-keychain-key) # exit
N7K-4-1(config-keychain) # int vlan 100
N7K-4-1(config-if) # ip authentication mode eigrp 200 md5
N7K-4-1(config-if) # ip authentication key-chain eigrp 200 NEXUS

Verification 6: Check now EIGRP neighbour.

N7K-4-1(config) # ip prefix-list default-only seq 5 permit 0.0.0.0/0 eq 32
N7K-4-1(config) # route-map default-to-eigrp permit 10
N7K-4-1(config-route-map) # match ip address prefix-list default-only
!
N7K-4-1(config) # router eigrp 200
N7K-4-1(config-router) # default-information originate route-map default-to-eigrp
!
N7K-4-1(config) # router eigrp 200
N7K-4-1(config-router) # redistribute maximum-prefix 100 75

Verification 7: Verify Eigrp Process


Comment

    You are will be the first.

LEAVE A COMMENT

Please login here to comment.