EMAIL SUPPORT

dclessons@dclessons.com

LOCATION

NZ

LAB Configuring Static RP

LAB Configuring Static RP

Posted on Jan 24, 2020 (0)

LAB Configuring Static RP

Topology:

Task:

  • Configure IP addressing as shown in above Diagram
  • Configure all interface of device in OSPF area 0
  • Configure PIM sparse mode in all interface connecting interface
  • Configure Loopback 0 of N7K2 as RP configure statically it on all devices.
  • Configure R2 E0/3 interface to join group 224.2.2.2
  • Test that all R1 must be able to reach to this group.

Solution:

R1 configuration:
ip multicast-routing
interface Ethernet0/3
ip address 10.10.11.2 255.255.255.0
ip pim sparse-mode
!
router ospf 10
network 0.0.0.0 255.255.255.255 area 0
!
ip pim rp-address 2.2.2.2
N7K1 configuration:
feature ospf
feature pim
ip pim rp-address 2.2.2.2 group-list 224.0.0.0/4
interface Ethernet2/2
no switchport
ip address 10.10.12.1/24
ip router ospf 10 area 0.0.0.0
ip pim sparse-mode
no shutdown
!
interface Ethernet2/3
no switchport
mac-address 0000.0000.002f
ip address 10.10.11.1/24
ip router ospf 10 area 0.0.0.0
ip pim sparse-mode
no shutdown
!
router ospf 10
N7K2 Configuration:
feature ospf
feature pim
ip pim rp-address 2.2.2.2 group-list 224.0.0.0/4
interface Ethernet2/1
no switchport
mac-address 0000.0000.002f
ip address 10.10.23.2/24
ip router ospf 10 area 0.0.0.0
ip pim sparse-mode
no shutdown
!
interface Ethernet2/2
no switchport
ip address 10.10.12.2/24
ip router ospf 10 area 0.0.0.0
ip pim sparse-mode
no shutdown
!
interface loopback0
ip address 2.2.2.2/32
ip router ospf 10 area 0.0.0.0
ip pim sparse-mode
!
router ospf 10

 

N7K3 Configuration:
feature ospf
feature pim
ip pim rp-address 2.2.2.2 group-list 224.0.0.0/4
interface Ethernet2/1
no switchport
ip address 10.10.23.3/24
ip router ospf 10 area 0.0.0.0
ip pim sparse-mode
no shutdown
!
interface Ethernet2/2
no switchport
ip address 10.10.34.3/24
ip router ospf 10 area 0.0.0.0
ip pim sparse-mode
no shutdown
!
router ospf 10
N7K4 Configuration:
feature ospf
feature pim
ip pim rp-address 2.2.2.2 group-list 224.0.0.0/4
interface Ethernet2/2
no switchport
ip address 10.10.34.4/24
ip router ospf 10 area 0.0.0.0
ip pim sparse-mode
no shutdown
!
interface Ethernet2/3
no switchport
mac-address 0000.0000.002f
ip address 10.10.42.4/24
ip router ospf 10 area 0.0.0.0
ip pim sparse-mode
no shutdown
!
router ospf 10
!
R2 Configuration:
interface Ethernet0/3
ip address 10.10.42.2 255.255.255.0
ip pim sparse-mode
ip igmp join-group 224.2.2.2
!
router ospf 10
network 0.0.0.0 255.255.255.255 area 0
!
ip multicast-routing

Verification:

Ping R1 to group 224.2.2.2

Here only R2 is replying. And R1 is acting as server.

Verify the PIM neighbour ship on devices:

To verify the static RP validation:

Now when R2 will join the 224.2.2.2 the verify the mroute table and you must verify the route table of each device along with flags and OIL and IIL interface.


[/pms-restrict]


Comment

    You are will be the first.

LEAVE A COMMENT

Please login here to comment.