EMAIL SUPPORT

dclessons@dclessons.com

LOCATION

NZ

LAB OTV Configuration

LAB OTV Configuration

Posted on Jan 24, 2020 (0)

LAB OTV Configuration

Task:

Configuration the following OTV task so that HOST1 can ping to HOST2 over Overlay.

  • Configure N5K1 and N5K2 Eth2/3 on VLAN 10 and configure HOST1 as IP 10.10.10.4 and HOST2 with IP 10.10.10.5
  • Configure Trunk on LINK Eth2/2 between N7k1 and N5K1 and N7K2 and N5K2
  • Configure N7K1 and N7K2 as STP root
  • Configure Eth2/1 on N7K1 with IP 192.168.1.1/24 and Eth2/1 on N7K2 with IP 192.168.1.2/24 and make it as join interface.
  • Enable OTV feature on N&K1 and N7K2
  • Configure 999 as Site VLAN between N7K1 and N7K2
  • Configure N7K1 with Site Identifier: 0X101
  • Configure N7K2 with Site Identifier: 0X102
  • Enable IGMPV3 on join interface
  • Configure Overlay on N7K1 and N7K2 with 232.1.1.0/24 as data group and 224.1.1.1 as OTV Control group.
  • Extend VLAN 10 between these two DC.
  • Verify OTV by reaching HOST1 to HOST2.

Topology:

Solution:

N5K1(config)# vlan 10
N5K1(config-vlan)# int eth2/2
N5K1(config-if)# switchport
N5K1(config-if)# switchport mode trunk
N5K1(config-if)# no shut
N5K1(config-if)# int eth2/3
N5K1(config-if)# switchport
N5K1(config-if)# switchport access vlan 10
N5K1(config-if)# no shut
N5K1(config-if)#
!
N5K2(config)# vlan 10
N5K2(config-vlan)# exit
N5K2(config)# int eth2/2
N5K2(config-if)# switchport
N5K2(config-if)# switchport mode trunk
N5K2(config-if)# no shut
N5K2(config-if)# exit
N5K2(config)# int eth2/3
N5K2(config-if)# switchport
N5K2(config-if)# switchport access vlan 10
N5K2(config-if)# no shut
N5K2(config-if)#
!
N7K1(config)# feature otv
N7K1(config)# feature pim
N7K1(config)# vlan 10
N7K1(config-vlan)# spanning-tree vlan 10 priority 4096
N7K1(config)# vlan 999
N7K1(config-vlan)# name SITE_VLAN
N7K1(config-vlan)# exit
N7K1(config)# otv site-vlan 999
N7K1(config-site-vlan)# exit
N7K1(config)# otv site-identifier 0x101
N7K1(config)# int overlay 1
N7K1(config-if-overlay)# otv join-interface eth2/1
N7K1(config-if-overlay)# otv control-group 224.1.1.1
N7K1(config-if-overlay)# otv data-group 232.1.1.0/24
N7K1(config-if-overlay)# otv extend-vlan 10
N7K1(config-if-overlay)# no shut
N7K1(config-if-overlay)#
N7K1(config)# int eth2/1
N7K1(config-if)# no switchport
N7K1(config-if)# ip address 192.168.1.1/24
N7K1(config-if)# ip igmp version 3
N7K1(config-if)# no shut
N7K1(config-if)#
N7K1(config)# int eth2/2
N7K1(config-if)# switchport
N7K1(config-if)# switchport mode trunk
N7K1(config-if)# no shut
N7K1(config-if)#
!

 

N7K2(config)# feature otv
N7K2(config)# feature pim
N7K2(config)# vlan 10
N7K2(config-vlan)# exit
N7K2(config)# spanning-tree vlan 10 priority 4096
N7K2(config)#
N7K2(config)# vlan 999
N7K2(config-vlan)# name SITE_VLAN
N7K2(config-vlan)# exit
N7K2(config)# otv site-vlan 999
N7K2(config-site-vlan)# exit
N7K2(config)# otv site-identifier 0x102
N7K2(config)# int overlay 1
N7K2(config-if-overlay)# otv join-interface Eth2/1
N7K2(config-if-overlay)# otv control-group 224.1.1.1
N7K2(config-if-overlay)# otv data-group 232.1.1.0/24
N7K2(config-if-overlay)# otv extend-vlan 10
N7K2(config-if-overlay)# no shut
N7K2(config-if-overlay)# exit
N7K2(config)#
N7K2(config-if)# int eth2/1
N7K2(config-if)# no switchport
N7K2(config-if)# ip address 192.168.1.2/24
N7K2(config-if)# ip igmp version 3
N7K2(config-if)# no shut
N7K2(config-if)# exit
N7K2(config)#
N7K2(config)# int eth2/2
N7K2(config-if)# switchport
N7K2(config-if)# switchport mode trunk
N7K2(config-if)# no shut

Verification: OTV can be verified by show otv command where we can see that Overlay tunnel is UP with all the control group and data group Multicast address.

By Seeing mroute table we can easily identify that for (*,G) ( *,224.1.1.1/32) the incoming and outgoing interface is properly populated.

Now once these all has been done, once must Identify weather OTV ISIS adjacency has been formed between both Site or not, this can be easily identified by following:

Now to check weather MAC address of HOST1 has been advertised to Site-2 N7K2 or not we should Run following command:

Now check the reachability by Ping HOST1 to HOST 2.




Comment

    You are will be the first.

LEAVE A COMMENT

Please login here to comment.