EMAIL SUPPORT

dclessons@dclessons.com

LOCATION

NZ

Routing Configuration Example

Routing Configuration Example

Posted on Jan 27, 2020 (0)

Routing Configuration Example

In this section we will learn how Viptela behaves while configuring Viptela Routing components. Let’s see how unicast routing is enabled on Cisco Viptela Network which consists of one vBond, one vSmart, and two vEdge router at two sites.

Topology:

IP address & Configuring Planning:


vSmart Controller Configuration

On the vSmart controller:

In first steps of Configure Viptela Routing , Configure the system properties of the vSmart controller:

vSmart1(config)# system system-ip 1.1.1.9
vSmart1(config-system)# domain-id 1
vSmart1(config-system)# site-id 50
vSmart1(config-system)# vbond 184.168.0.69

Configure the physical transport information:

Configure the IP address of the WAN-facing interface:

vSmart1(config)# vpn 0 interface eth4 ip address 10.0.16.19/24

Allow the interface to carry control-plane traffic:

vSmart1(config)# vpn 0 interface eth4 tunnel-interface

Enable the interface:

vSmart1(config)# vpn 0 interface eth4 no shutdown

Configure a default route to the WAN interface that connects to the transport cloud:

vSmart1(config)# vpn 0 ip route 0.0.0.0/0 10.0.16.19

Commit the configuration:

vSmart1(config)# commit

Full Configuration:

system
system-ip 1.1.1.9
domain-id 1
site-id 50
vbond 184.168.0.69
!
vpn 0
interface eth4
ip address 10.0.16.19/24
tunnel-interface
!
no shutdown
!
ip route 0.0.0.0/0 10.0.16.19
!

vEdge1 Router Configuration

On the vEdge1 router:

OMP is enabled by default on the vEdge router. This branch network is running BGP, and we want to advertise BGP learned routes to the vSmart controller:

vEdge1(config)# omp advertise bgp

Configure the system properties of the vEdge1 router and the IP address of the vBond orchestrator:

vEdge1(config)# system system-ip 1.1.1.5
vEdge1(config-system)# domain-id 1
vEdge1(config-system)# site-id 1
vEdge1(config-system)# vbond 184.168.0.69

Configure the transport VPN and the transport interface:

vEdge1(config)# vpn 0 interface ge1/1 ip address 75.0.13.15/24
vEdge1(config-ge1-1)# tunnel-interface
vEdge1(config-ge1-1)# no shutdown/span>

Configure the default route in the transport VPN:

vEdge1(config-vpn-0)# ip route 0.0.0.0/0 75.0.13.15

For the VPN, configure BGP:

Configure the local AS number:

vEdge1(config)# vpn 1 router bgp 1

Have BGP advertise only unicast traffic:

vEdge1(config-bgp-1)# address-family ipv4_unicast

Have BGP redistribute routes that it learns, via the OMP session, from the vSmart controller:

vEdge1(config-bgp-1)# redistribute omp

Enable and configure the BGP peer:

vEdge1(config-bgp-1)# neighbor 10.0.17.17 remote-as 2
vEdge1(config-bgp-1)# no shutdown

Configure the interface between the vEdge1 router and its local-site router:

vEdge1(config-bgp-1)# vpn 1 interface ge0/1
vEdge1(config-interface-ge1-1)# no shutdown

Activate the configuration:

vEdge1(config)# commit

Full Configuration

omp
no shutdown
advertise bgp
!
system
system-ip 1.1.1.5
domain-id 1
site-id 1
vbond 184.168.0.69
!
vpn 0
interface ge1/1
ip address 75.0.13.15/24
tunnel-interface
!
no shutdown
ip route 0.0.0.0/0 75.0.13.15
!
vpn 1
router
bgp 1
address-family ipv4_unicast
redistribute omp
!
neighbor 10.0.17.17
no shutdown
remote-as 2
!
!
!
interface ge0/1
ip address 10.0.19.15/24
!
!

vEdge2 Router Configuration

On the vEdge2 router:

OMP is enabled by default on the vEdge router. This branch network is running OSPF, and OSPF automatically redistributes its learned intra-area and inter-area routes to the vSmart controller. We also want to advertise OSPF external routes to the vSmart controller:

vEdge2(config)# omp advertise ospf external

Configure the system properties of the vEdge2 router and the IP address of the vBond orchestrator:

vEdge2(config)# system system-ip 1.1.1.6
vEdge2(config-system)# domain-id 1
vEdge2(config-system)# site-id 2
vEdge2(config-system)# vbond 184.168.0.69

Configure the transport VPN and the transport interface and the default route:

vEdge2(config)# vpn 0 interface ge2/1 ip address 172.16.10.16/24
vEdge2(config-ge2-1)# tunnel-interface
vEdge2(config-ge2-1)# no shutdown

Configure the default route in the transport VPN:

vEdge2(config-vpn-0)# ip route 0.0.0.0/0 172.16.10.16

For the VPN, configure OSPF:

Configure area 0 and add the ge0/2 interface to this area:

vEdge2(config)# vpn 2 router ospf area 0 interface ge0/2

Configure the interface between the vEdge2 router and its local-site router:

vEdge2(config)# vpn 2 interface ge0/2 ip address 172.16.7.16/24
vEdge2(config-interface-eth1)# no shutdown

Activate the configuration:

vEdge1(config)# commit

Full configuration

omp
no shutdown
advertise ospf external
!
system
system-ip 1.1.1.6
domain-id 1
site-id 2
vbond 184.168.0.69
!
vpn 0
interface ge2/1
ip address 172.16.10.16/24
tunnel-interface
!
no shutdown
!
ip route 0.0.0.0/0 172.16.7.16
!
vpn 2
router
ospf
area 0
interface ge0/2
exit
exit
!
!
interface ge0/2
ip address 172.16.7.16/24
no shutdown
!
!


Comment

    You are will be the first.

LEAVE A COMMENT

Please login here to comment.