MPLS: The routing protocol for speeding up network traffic.

MPLS Protocol is the complex routing protocol that literally speeds the network work.
This tutorial walks you through how BGP works and offers troubleshooting options.
MPLS allows most packets to be forwarded at Layer 2 (the switching level) rather than having to be passed up to Layer 3 (the routing level). Each packet gets labeled on entry into the service provider’s network by the ingress router. All the subsequent routing switches perform packet forwarding based only on those labels—they never look as far as the IP header. Finally, the egress router removes the label(s) and forwards the original IP packet toward its final destination.

 

Task:

  • Power On R1, R2, R3, SW1 and SW2 and load the initail configuration of the following devices R1, R2, R3 , SW1, SW2 and check the network connectivity between Routers as per Logical Topology. (14 Arial)
  • Configure Eigrp with AS 123 and advertise directly connected interface IP address.
  • Configure Full Mesh iBGP adjecency between R1, R2, R3 with their interface IP address .
  • Configure and advertise loopback 0 interfaces in BGP of each Routers .
  • Check full IPV4 reachibility for Loopack 0 prefixes of R1, R2 ,R3

Task Configuration

Once the Initial Configuration is loaded to the devices check the ping test . Each Router directly connected interface IP address will be pingable .

login: admin

R2#ping 12.12.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 msR3#ping 23.23.23.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R3#

CONFIGURATION

Follow the following configuration to achieve the task solution .

R1 Configuration:

router eigrp 123
network 12.12.12.1 0.0.0.0
no auto-summary
!

router bgp 123
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
neighbor 12.12.12.2 remote-as 123
neighbor 23.23.23.3 remote-as 123
!

R2 Configuration:

router eigrp 123
network 12.12.12.2 0.0.0.0
network 23.23.23.2 0.0.0.0
no auto-summary
!
router bgp 123
bgp log-neighbor-changes
network 2.2.2.2 mask 255.255.255.255
neighbor 12.12.12.1 remote-as 123
neighbor 23.23.23.3 remote-as 123
!

R3 Configuration:

router eigrp 123
network 23.23.23.3 0.0.0.0
no auto-summary
!
router bgp 123
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
neighbor 12.12.12.1 remote-as 123
neighbor 23.23.23.2 remote-as 123
!

To begin with test the IPV4 reachibility for Loopback 0 prefixes of R1 , R2, R3 Routers.

BGP does not have its own transport protocol and IGP reachibility must be established to allow TCP 179 session to be successful between neighbours. BGP is TCP application which initiates TCP SYN packet to TCP server on port 179. Once BGP server accept the SYN packet , it reply with SYN/ACK from port 179 back to TCP Client ( BGP Peer Neighbour ) which is high port number generated or used by TCP Client ( BGP Peer ).

It may be that both BGP peer can attempt to establish TCP connection on same time , so to avoid this BGP uses its ” BGP Connection Collision Detection ” method , in which session generated from device with high BGP router-id is maintained and secondary session is dropped.

To check with above explanation about iBGP peering between R2 and R3 . Check the debug output .

ABCDE
FGHIJ
KLMNO
PQRST
Subscription-plan Overall rating: 0 out of 5 based on 0 reviews.
Name
Rating